2015年7月24日 星期五

在Ubuntu中QMake版本轉換 (Change Version of Qmake on Ubuntu)

#以下範例是由Qt4轉成Qt5

首先,先找到/usr/lib/x86_64-linux-gnu/qt-default/qtchooser/default.conf
$sudo gedit default.conf

把下面兩行改成你放置QT bin資料夾的位置就可以了,就像設定環境變數。
  • /usr/lib/x86_64-linux-gnu/qt5/bin
  • /usr/lib/x86_64-linux-gnu

改完檢查版本看看是否有修改成功
$qmake --version
>>>
Qmake version 3.0
Using Qt version 5.2.1 in /usr....

如果系統中有兩個QT5的版本,必須在/usr/lib/x86_64-linux-gnu/qtchooser中,找到qt5的conf檔改成指定的版本路徑。

0 意見:

張貼留言